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MMT Dobby Designer - V1.5
Professional User Manual

Mudassar Multi Tech (MMT)

Real application screenshot used in this manual.

This manual explains the stable MMT Dobby Designer V1.5 interface, menus, drawing tools, program library, Auto Recovery, keyboard shortcuts, and export workflows. The
screenshots are real screenshots from the software interface. Unused icons are not included in the toolbar reference.

Manual language: English. Software UI language: English. The manual is intended for operators, designers, and controller-file preparation staff.



MMT Dobby Designer V1.5 User Manual - Mudassar Multi Tech Page 2

Contents
- 1. Software overview and design concept

- 2. Main workspace layout

- 3. Creating a new design

- 4. Drawing cells and working with harness, color, and density columns

- 5. Left draw tools, right edit tools, top toolbar, and status bar

- 6. File, Edit, Design, Weave, View, Tools, Dobby File, Image, and Help menus

- 7. Pick direction: Design View and Loom View

- 8. Program Library and Apply Range

- 9. Right-click menu, rotation, weave tools, and selection operations

- 10. Text Sticker / Number tool

- 11. Auto Recovery backup system

- 12. Export formats: MCR, EDB, JC5, BMP, Lits, and Loom files

- 13. Keyboard shortcuts reference

- 14. Toolbar icon reference

- 15. Recommended workflow and safety notes

Note: Some features are explained from the stable software file even if a separate screenshot was not available. No fake screenshots are used.



MMT Dobby Designer V1.5 User Manual - Mudassar Multi Tech Page 3

1. Software Overview

Main MMT Dobby Designer V1.5 workspace.

- MMT Dobby Designer is a pick-based dobby design application for creating harness/frame patterns, color selections, and density data.

- The main grid is divided into Harness, Color, and DEN areas. Harness columns are F1 to F28. Color columns are C1 to C8. Density is shown as D1.

- A black cell means ON. A white/blank cell means OFF. This is the most important design rule for controller output.

- The left side contains drawing tools, brush size, and color selection. The right side contains editing tools such as vertical/horizontal selection, invert, clear, go to pick, add/remove
picks, and resize.

- The bottom status bar shows total picks, start/end pick, current mouse or keyboard position, current ON/OFF state, operation progress, Auto Recovery state, and product branding.
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2. Workspace, Active Cell, and Status Bar

Bottom status bar and live cell information.

- The status bar gives live feedback while moving the mouse or keyboard selection over the design.

- It can display the current pick number, frame/color/density column, and whether the cell is currently ON or OFF.

- When a save/export operation takes time, the progress bar and percentage are shown in the status bar area.

- The orange highlight shows the active row and active column. This makes it easier to see the exact pick and output currently being edited.

- Mouse movement updates the active position. Keyboard arrow movement continues from the current active position and updates the status bar as well.
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3. Creating a New Design

File menu with New Design, open, save, Loom, Lits, and BMP commands.

- Use File > New Design or Ctrl+N to start a new design.

- Use File > Open MDD Dobby Design File (.mdd) or Ctrl+O to open the software native design file.

- Use File > Save MDD Dobby Design File (.mdd) or Ctrl+S to save the current design in the native format.

- Use Save As when you want to create a separate copy under a new file name.

- Loom (.lom), Lits text (.txt), and BMP 40-column files are available from the File menu for compatibility workflows.
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3.1 New Design Pick Count

New Design dialog asking for total picks.

- The New Design dialog asks for the total number of picks to create.

- Enter the required pick count and press OK. Press Cancel to stop creating a new design.

- The software creates a blank design grid with fixed outputs: 28 harness frames, 8 colors, and 1 density column.

- The total pick count can later be changed using Add Picks at End, Remove Picks from End, or Resize Design.
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3.2 Blank Design Ready for Drawing

New blank design grid after creating 10 picks.

- After the design is created, the grid shows blank cells ready for editing.

- The Harness section is used for frame magnets. The Color section is used for color outputs. The DEN section is used for density D1.

- The left row labels show Pick 1, Pick 2, and so on. The top headers show F1 to F28, C1 to C8, and D1.
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4. Drawing on the Grid

Example pattern drawn on the harness grid.

- Select the Pencil/Draw tool to mark cells ON. Click a cell to toggle or mark it depending on the active tool mode.

- Use the Eraser tool to clear cells OFF.

- Use the brush size buttons 1, 3, and 5 when drawing wider marks or quick blocks.

- Use black for normal ON drawing. White is OFF. Other color swatches are visual drawing aids and still mark cells as ON.

- Always confirm the status bar if you need to verify the exact pick, frame, color, or density cell under the pointer.
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4.1 Draw Tool Tooltip

Pencil tool tooltip showing mark cells ON.

- Tooltips appear when the mouse is placed over a tool button.

- The Pencil tool is used to mark cells ON. It is the normal drawing tool for entering dobby lifting points.

- The active tool is highlighted in orange on the left tool panel.
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5. Top Toolbar

Close-up of top toolbar icons.

- The top toolbar gives quick access to the most common commands: new, open, save, undo, redo, cut, copy, paste, clear, repeat, calculator, fit, zoom, grid, MCR export, and
program library.

- Icons are separated into groups with orange separator marks.

- The right side of the toolbar contains the MMT branding panel.

- Only icons that are actually used in the software are documented in the toolbar reference section.
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5.1 Left Draw Tools

Upper part of the left draw tools panel.

- The left draw tools panel contains drawing and shape tools.

- Pencil marks cells ON. Eraser clears cells OFF. Fill applies fill to a section or selected area. Picker samples a screen color.

- Text adds text/number stickers on the grid. Select activates block selection, move, and floating paste workflows.

- Line, rectangle, filled rectangle, and ellipse tools allow CAD-style drawing on the cell grid.
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5.2 Brush Size and Color Palette

Lower part of left draw tools: size buttons and color palette.

- The size buttons 1, 3, and 5 control drawing brush size.

- The color palette changes the active drawing color display. Black represents ON and white represents OFF.

- Colored swatches are useful for visual drafting, but the export logic is based on ON/OFF cell states.

- The Active Tool text at the bottom shows the selected tool, color, and brush size.
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5.3 Right Edit Tools

Right-side edit toolbar.

- The right edit toolbar contains full column/row selection tools, invert, clear, go to pick, add picks, remove picks, and resize.

- Vertical full column/frame select is useful for selecting an entire frame column.

- Horizontal full pick row select is useful for selecting one complete pick row.

- Invert changes ON cells to OFF and OFF cells to ON in the selected or clicked area.

- Go To Pick jumps directly to a pick number. Add/Remove/Resize edit the overall pick count.
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6. Edit Menu

Edit menu with undo, redo, cut, copy, paste, select mode, and repeat.

- Undo and Redo reverse or restore design edits.

- Cut, Copy, and Paste work on selected blocks.

- Clear Selected Block clears the selected area to OFF.

- Select Mode allows block selection and keyboard-assisted selection. Esc clears the selection.

- Repeat Selected Range to End repeats the selected design block until the end of the design.
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7. Design Menu

Design menu for pick insertion, deletion, adding, removing, and resizing.

- Insert Pick adds a new pick at the selected/current position.

- Delete Pick removes a pick from the design.

- Add Picks at End appends new blank picks after the current last pick.

- Remove Picks from End removes picks from the end of the design.

- Resize Design changes the total design size. It is also available in the right-click menu.
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8. Weave Menu

Weave menu with transformation and cleaning tools.

- Mirror Harness Left / Right reverses the harness direction horizontally.

- Reverse Pick Order reverses the pick order vertically.

- Invert Harness ON / OFF inverts harness data.

- Move Harness Left/Right shifts harness data across frame columns.

- Move Picks to Next/Previous Pick shifts pattern rows forward or backward.

- Fill Harness Area, Clear Harness Area, and Clear Full Pattern are bulk editing tools.

- Keep One Color Per Pick and Fill Empty Color with C1 help clean color selections before export.
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9. View Menu

View menu with zoom, grid, toolbar, tool panels, status bar, and full screen.

- Fit to Window adjusts the grid view to the available screen area.

- Zoom In and Zoom Out change grid zoom level.

- Go To Pick jumps to a specific pick number.

- Pick Direction changes how pick numbers are displayed: Pick 1 at top or Pick 1 at bottom.

- Show Grid Lines, Show Top Toolbar, Show Left Draw Tools, Show Right Edit Tools, and Show Status Bar can hide/show interface parts.

- Full Screen switches to full screen view with F11.
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9.1 Pick Direction Submenu - Design View

Design View - Pick 1 Top.

- Design View shows Pick 1 at the top of the grid.

- This mode is convenient when designing from top to bottom on the screen.

- The software remembers the visible direction while exporting correctly according to the design data.
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9.2 Pick Direction - Loom View

Loom View - Pick 1 Bottom.

- Loom View shows Pick 1 at the bottom of the grid.

- This mode is useful when matching EasyWeave-style screenshots where Pick 1 is at the bottom.

- The selected pick direction changes the display order only. It helps operators compare the design with loom-side viewing.
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9.3 Loom View Result

Grid after selecting Loom View with Pick 1 at the bottom.

- The pick labels appear from bottom to top in Loom View.

- This is useful when reviewing designs that must visually match loom-side or EasyWeave bottom-up display.
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10. Tools Menu

Tools menu with Calculator and Auto Save/Auto Recovery.

- Calculator opens the built-in calculator window.

- Auto Save is the menu name for the Auto Recovery backup system.

- When Auto Recovery is ON, the toolbar displays an Auto Recovery ON button.
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10.1 Calculator

Built-in calculator window.

- The calculator can be opened from Tools > Calculator or Ctrl+K.

- It provides quick calculation without leaving the design software.

- The calculator is useful for repeat length, pick calculations, or quick arithmetic during pattern planning.
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10.2 Auto Recovery ON

Auto Recovery ON indicator on the toolbar.

- Auto Recovery stores a separate recovery backup and does not overwrite the main MDD file.

- When Auto Recovery is ON, the software saves recovery snapshots only when the design changes.

- The setting remains ON until the user manually turns it OFF. If turned OFF, it remains OFF until turned ON again.

- On startup, if a recovery backup is found, the software shows a restore prompt after the splash screen.

- If the user clicks Yes, the backup is restored. If the user clicks No, the old backup remains safe until the first new design change.
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11. Dobby File Menu

Dobby File menu with MCR export and EasyWeave compatibility submenu.

- Export MMT Controller Runtime File (*.mcr) creates the MMT controller running file.

- EasyWeave Compatibility contains JC5 open/export and EDB export commands.

- Before exporting MCR, EDB, or JC5, the software asks the user to save the design in MDD format if it is not already saved or if there are unsaved changes.

- BMP and Lits file saves are normal file workflows and are not blocked by this export safety requirement.
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11.1 Save Before Export Safety

Safety popup shown before export when the design is not saved in MDD format.

- This safety prevents controller/export files from being created from an unsaved design.

- Click Yes to save the design first, then continue export.

- Click No to cancel export.

- The safety applies to MCR, EDB, and JC5 export workflows.
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11.2 EasyWeave Compatibility Submenu

EasyWeave Compatibility submenu.

- Open EasyWeave JC5 File imports a JC5 file into the design grid.

- Export EasyWeave EDB File exports an EasyWeave EDB controller file.

- Export EasyWeave JC5 File exports a JC5 file using the confirmed EasyWeave JC5 mapping.

- Export EasyWeave JC5 File to USB writes a JC5 file directly to a selected USB drive.

- EasyWeave EDB and JC5 file names must be exactly 5 letters or numbers. Examples: 12345, ABCDE, A1B2C.



MMT Dobby Designer V1.5 User Manual - Mudassar Multi Tech Page 27

12. Image Menu

Image menu with Text Sticker / Number command.

- Text Sticker / Number opens the text drawing toolbar.

- It allows text or numbers to be converted into ON/OFF cell patterns on the grid.

- The shortcut is Ctrl+Shift+T.
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12.1 Text Sticker Preview

Text Sticker / Number preview on the design grid.

- Enter text in the Text field. The preview appears on the grid as a light blue selected area.

- Use Size - and Size + to adjust the text size.

- Use Rotate to rotate the text sticker.

- Mode Set ON Only adds ON cells without clearing the existing area. Overwrite Area writes the whole sticker area.

- Click Apply to place the text. Click Cancel or press Esc to stop.
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12.2 Text Sticker Applied

Text sticker result applied to the design.

- After Apply, the text becomes normal ON/OFF cells in the harness grid.

- The result can be edited, selected, copied, rotated, or exported like any other design data.
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12.3 Another Text Sticker Example

MMT text sticker preview.

- Text Sticker can be used for words, numbers, or labels inside the design area.

- Use the mouse to position the preview before applying.

- The top Text Sticker panel also displays the current pick, frame, size, and instructions such as Enter apply and Esc cancel.
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12.4 MMT Text Applied

MMT text applied on the grid.

- Once applied, the text is stored as cell data and becomes part of the design.

- Use Undo if the placement is not correct.
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13. Help Menu

Help menu with User Manual, Keyboard Shortcuts, and About.

- User Manual is the documentation entry for software guidance.

- Keyboard Shortcuts opens the shortcut help window.

- About MMT Dobby Designer opens product information and copyright details.
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13.1 Keyboard Shortcuts Window

Keyboard Shortcuts help window.

- The shortcuts window lists the most important keyboard commands by category.

- Use keyboard shortcuts to speed up professional design work.

- The full shortcut reference is included later in this manual.
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14. Program Library

Program Library with built-in dobby designs and preview.

- Program Library contains built-in basic dobby patterns such as Plain, Basket, Twill, Broken Twill, Herringbone, Chevron, Diamond, Zigzag, Wave, and Satin patterns.

- Select a library pattern on the left to preview it on the right.

- Save Selection stores the current selected design block as a user library pattern.

- Delete User deletes user-saved library patterns.

- Apply applies the selected library pattern using the normal selection/active-area behavior.

- Apply Range opens a custom range dialog for pick and frame range control.
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14.1 Program Library Apply Range

Apply Range dialog with custom Pick From/To and Frame From/To.

- Apply Range allows manual entry of Pick From, Pick To, Frame From, and Frame To.

- Pick numbers are 1-based. Frame numbers are limited to F1 through F28.

- The Apply size line shows how many picks and frames will be affected.

- Click Apply to write the selected library pattern into that range. Click Cancel to stop.
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14.2 Program Library Range Applied

Library pattern applied in the selected range.

- The library pattern is repeated/fitted into the selected pick and frame range.

- Only the selected frame range is affected. Other frames remain unchanged.

- This is useful for quickly applying weave structures to a specific area of the design.
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14.3 Apply Range on F17 to F28

Apply Range using frames 17 to 28.

- Frame From and Frame To can target any valid harness range from 1 to 28.

- If a value above 28 is entered, the software blocks it with an error because the design has a fixed 28-frame harness section.
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14.4 Apply Range Result on Upper Frames

Result after applying the library pattern to the upper frame range.

- The applied pattern appears only in the requested frame range.

- This allows different weave structures to be placed in different harness sections.
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14.5 Apply Range with More Picks Than Current Design

Apply Range asks for Pick To 28 while current design has 10 picks.

- If the target pick range needs more picks than the current design has, the software displays a confirmation prompt.

- This prevents accidental resizing or data loss.
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14.6 More Picks Prompt

Prompt asking whether to add required picks automatically.

- Yes adds the required picks automatically and applies the library pattern.

- No fits only inside the current pick count.

- Cancel stops the operation without applying the range.
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14.7 Expanded Design After Adding Picks

Result after adding required picks and applying the range.

- After choosing Yes, the design is expanded to the required pick count.

- The status bar updates the total pick count.

- The selected library pattern is then applied into the requested range.
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15. Right-Click Menu

Main right-click menu.

- Right-click on the grid to open the context menu.

- Cut, Copy, and Floating Paste work with selected blocks.

- Fill Selected / Region fills the active selected area or region.

- Clear OFF clears selected cells. Invert changes ON to OFF and OFF to ON.

- Select Full Pick Row selects an entire pick row. Select Full Column selects an entire output column.

- Copy Selection Continuous repeats a selected block with count and spacing options.

- Add Selection to Library saves the current selection as a library item. Program Library opens the library window.

- Insert Pick Below, Delete Pick, Add Picks at End, and Resize Design are available directly from the right-click menu.
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15.1 Right-Click Rotation Submenu

Rotate Selection / Paste submenu.

- Rotate 90 Clockwise rotates the selected block or floating paste preview by 90 degrees.

- Rotate 180 rotates by 180 degrees.

- Rotate 270 Clockwise rotates by 270 degrees.

- Rotation is intended for selected blocks and floating paste previews. After rotating a floating paste preview, click to apply it.

- Rotation is safety-checked so it does not cross unsupported sections.
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15.2 Right-Click Weave Tools Submenu

Right-click Weave Tools submenu.

- The Weave Tools submenu provides quick access to the same weave operations from the main Weave menu.

- It includes mirror, reverse, invert, move, fill, clear, apply basic patterns, keep one color, and fill empty color commands.

- This saves time because operators can use weave commands directly from the grid area.
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16. Grid Lines On / Off

Design view with grid lines hidden.

- Show Grid Lines can be toggled from the View menu or toolbar grid icon.

- Turning grid lines off gives a cleaner preview of the design pattern.

- Turning grid lines on is better for accurate cell editing.
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17. File Formats and Export Safety
Format Purpose Important rules

MDD (.mdd) Native MMT Dobby Design file. Use this for saving and
editing the design project.

Must be saved before MCR, EDB, or JC5 export. This is the main software design file.

MCR (.mcr) MMT Controller Runtime file for MMT controller operation. Export only. Save-before-export safety applies.

JC5 (.jc5) EasyWeave / JC5 compatibility file. Can be opened and
exported.

Name must be exactly 5 letters/numbers when exporting. D2 is not used and remains OFF/zero.

EDB (.edb) EasyWeave EDB controller export file. Export only. Name must be exactly 5 letters/numbers. Roti/PU prompt appears before export.

Loom (.lom) Loom file compatibility format. Open/save from File menu.

Lits Text (.txt) Lits text file compatibility output. Normal file save/open workflow. It is not part of save-before-export safety.

BMP 40 Columns
(.bmp)

Bitmap import/export format with 40-column layout. 40-column layout: 28 Harness + space + 8 Color + space + 2 Density. Normal file workflow.

Save-before-export safety applies only to true export formats: MCR, EDB, and JC5. BMP and Lits are not blocked by this safety because they are normal compatibility
save/open workflows.

EasyWeave file name rule: EDB and JC5 export names must be exactly 5 characters, using letters and/or numbers only. Examples: 12345, ABCDE, A1B2C. Less than 5 or more
than 5 characters are rejected.

Export progress: for large files, the status bar shows a progress bar and percentage so the operator can see that the software is still working.
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18. Keyboard Shortcuts Reference
Menu Shortcut Command

File Ctrl+N New Design

File Ctrl+O Open MDD Dobby Design File

File Ctrl+S Save MDD Dobby Design File

File Ctrl+Shift+S Save As MDD Dobby Design File

File Ctrl+Alt+O Open Loom File

File Ctrl+Alt+S Save Loom File

File Ctrl+Alt+Shift+S Save Loom File As

File Ctrl+Alt+L Open Lits File

File Ctrl+Shift+L Save As Lits File

File Ctrl+Alt+B Open BMP Bitmap File

File Ctrl+Shift+B Save As BMP Bitmap File

File Alt+F4 Exit

Edit Ctrl+Z Undo

Edit Ctrl+Y Redo

Edit Ctrl+X Cut Selected Block

Edit Ctrl+C Copy Selected Block

Edit Ctrl+V Paste Block / Floating Paste

Edit Ctrl+Delete Clear Selected Block

Edit Ctrl+M Select Mode

Edit Esc Clear Selection / cancel preview

Edit Ctrl+R Repeat Selected Range to End

Edit Space Toggle active selected cell

Edit Ctrl+Space Toggle selected cell in Select Mode

Edit Arrow keys Move active selection

Design Ctrl+Shift+I Insert Pick

Design Ctrl+Shift+D Delete Pick

Design Ctrl+Shift+A Add Picks at End

Design Ctrl+Shift+E Remove Picks from End
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Menu Shortcut Command

Design Ctrl+Shift+R Resize Design

Weave Ctrl+Alt+M Mirror Harness Left / Right

Weave Ctrl+Alt+R Reverse Pick Order

Weave Ctrl+Alt+I Invert Harness ON / OFF

Weave Ctrl+Alt+Left Move Harness Left

Weave Ctrl+Alt+Right Move Harness Right

Weave Ctrl+Alt+Down Move Picks to Next Pick

Weave Ctrl+Alt+Up Move Picks to Previous Pick

Weave Ctrl+Alt+F Fill Harness Area

Weave Ctrl+Alt+H Clear Harness Area

Weave Ctrl+Alt+X Clear Full Pattern

Weave Ctrl+Alt+K Keep One Color Per Pick

Weave Ctrl+Alt+C Fill Empty Color with C1

View Ctrl+0 Fit to Window

View Ctrl++ Zoom In

View Ctrl+- Zoom Out

View Ctrl+G Go To Pick

View Ctrl+L Show / Hide Grid Lines

View Ctrl+T Show / Hide Top Toolbar

View Ctrl+B Show / Hide Status Bar

View F11 Full Screen

Tools Ctrl+K Calculator

Tools Ctrl+Alt+A Auto Recovery ON / OFF

Dobby File Ctrl+Alt+J Export MMT Controller Runtime File (*.mcr)

Dobby File Ctrl+Alt+E Export EasyWeave EDB File

Dobby File Ctrl+Alt+Shift+O Open EasyWeave JC5 File

Dobby File Ctrl+Alt+Shift+J Export EasyWeave JC5 File

Dobby File Ctrl+Alt+Shift+U Export EasyWeave JC5 File to USB

Image Ctrl+Shift+T Text Sticker / Number



MMT Dobby Designer V1.5 User Manual - Mudassar Multi Tech Page 49

19. Toolbar and Tool Icon Reference
This section includes only icons that are actually used in the visible software interface. The JC5 image asset is not listed here as a toolbar icon because JC5 is
accessed through the Dobby File menu, not the toolbar.

New Design
Create a new blank design.

Open MDD
Open native MDD design file.

Save MDD
Save native MDD design file.

Undo
Undo last design action.

Redo
Redo last undone action.

Cut
Cut selected block.

Copy
Copy selected block.

Paste
Paste or floating paste selected block.

Clear
Clear selected cells OFF.

Repeat
Repeat selected range to end.

Calculator
Open calculator.

Fit to Window
Fit design grid to the window.

Zoom In
Increase grid zoom.

Zoom Out
Decrease grid zoom.

Grid Lines
Show or hide grid lines.

MCR Export
Export MMT Controller Runtime File.

Program Library
Open basic dobby design library.

Pencil / Draw
Mark cells ON.

Eraser
Clear cells OFF.

Fill
Fill section or selected area.

Color Picker
Pick a screen color.

Text Sticker
Add text or number pattern.

Select
Select, move, or floating paste.

Line
Draw line between two points.

Rectangle
Draw rectangle outline.

Filled Rectangle
Draw filled rectangle.

Ellipse
Draw circle or ellipse.

Vertical Line
Select full column/frame.

Horizontal Line
Select full pick row.

Invert
Invert clicked/selected area.

Go To Pick
Jump to a pick.

Add Picks
Add picks at end.

Remove Picks
Remove picks from end.

Resize
Resize design.
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20. Recommended Professional Workflow
- Create a new design with the required pick count.

- Draw or import the pattern using the grid, Program Library, Text Sticker, or file import tools.

- Use Pick Direction to view the design in the direction required for checking.

- Use Edit, Design, Weave, and right-click tools to clean and finalize the design.

- Save the design as MDD (.mdd). This is the main editable project file.

- If the design is for the MMT controller, export MCR (.mcr).

- If EasyWeave compatibility is needed, export EDB or JC5 using exactly 5-character file names.

- For USB export workflows, insert the correct USB drive and select the target drive carefully.

- Use Auto Recovery during design work to keep a separate backup, but still manually save the MDD file for final work.

- Before production use, open the exported file on the target controller/software and verify the first picks and critical color/density points.

Operator safety note: Never run a controller file on the machine until the design has been checked. Confirm harness outputs, color outputs, and density D1 before
production.


